CVE-2018-12891

Priority
Description
An issue was discovered in Xen through 4.10.x. Certain PV MMU operations
may take a long time to process. For that reason Xen explicitly checks for
the need to preempt the current vCPU at certain points. A few rarely taken
code paths did bypass such checks. By suitably enforcing the conditions
through its own page table contents, a malicious guest may cause such
bypasses to be used for an unbounded number of iterations. A malicious or
buggy PV guest may cause a Denial of Service (DoS) affecting the entire
host. Specifically, it may prevent use of a physical CPU for an
indeterminate period of time. All Xen versions from 3.4 onwards are
vulnerable. Xen versions 3.3 and earlier are vulnerable to an even wider
class of attacks, due to them lacking preemption checks altogether in the
affected code paths. Only x86 systems are affected. ARM systems are not
affected. Only multi-vCPU x86 PV guests can leverage the vulnerability. x86
HVM or PVH guests as well as x86 single-vCPU PV ones cannot leverage the
vulnerability.
Notes
 mdeslaur> hypervisor packages are in universe. For
 mdeslaur> issues in the hypervisor, add appropriate
 mdeslaur> tags to each section, ex:
 mdeslaur> Tags_xen: universe-binary
Package
Source: xen (LP Ubuntu Debian)
Upstream:released (4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u9)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.04 (Disco Dingo):needed
Ubuntu 19.10 (Eoan):needed
Binaries built from this source package are in universe and so are supported by the community. For more details see https://wiki.ubuntu.com/SecurityTeam/FAQ#Official_Support
More Information

Updated: 2019-09-19 14:43:49 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)