CVE-2018-12581

Priority
Description
An issue was discovered in js/designer/move.js in phpMyAdmin before 4.8.2.
A Cross-Site Scripting vulnerability has been found where an attacker can
use a crafted database name to trigger an XSS attack when that database is
referenced from the Designer feature.
Ubuntu-Description
It was discovered phpmyadmin incorrectly handled database names. An
attacker could possibly use this to trigger an XSS attack.
Notes
Package
Upstream:released (4.8.2, 4:4.9.1+dfsg1-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (4:4.9.2+dfsg1-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (4:4.9.2+dfsg1-1)
Patches:
Upstream:https://github.com/phpmyadmin/phpmyadmin/commit/6943fff87324bd54c3a37a5160a5fb77498c355e
More Information

Updated: 2020-07-31 22:14:23 UTC (commit 44c3be61aff7f7dcecb4501154cd3ca8a057b5df)