CVE-2018-12034

Priority
Description
In YARA 3.7.1 and prior, parsing a specially crafted compiled rule file can
cause an out of bounds read vulnerability in yr_execute_code in
libyara/exec.c.
Package
Source: yara (LP Ubuntu Debian)
Upstream:released (3.7.1-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 19.04 (Disco Dingo):not-affected (3.7.1-3)
Ubuntu 19.10 (Eoan):not-affected (3.7.1-3)
More Information

Updated: 2019-08-23 07:50:54 UTC (commit 436fd4ed4cf0038ddd382cb8649607ace163dda7)