CVE-2018-12020

Priority
Description
mainproc.c in GnuPG before 2.2.8 mishandles the original filename during
decryption and verification actions, which allows remote attackers to spoof
the output that GnuPG sends on file descriptor 2 to other programs that use
the "--status-fd 2" option. For example, the OpenPGP data might represent
an original filename that contains line feed characters in conjunction with
GOODSIG or VALIDSIG status codes.
Ubuntu-Description
Marcus Brinkmann discovered that GnuPG before 2.2.8 improperly handled certain
command line parameters. A remote attacker could use this to spoof the output
of GnuPG and cause unsigned e-mail to appear signed.
Assigned-to
sbeattie
Notes
Package
Upstream:released (2.0.7)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):needed
Ubuntu 20.10 (Groovy Gorilla):needed
Package
Source: gnupg (LP Ubuntu Debian)
Upstream:released (1.4.18-7+deb8u5)
Ubuntu 12.04 ESM (Precise Pangolin):released (1.4.11-3ubuntu2.11)
Ubuntu 14.04 ESM (Trusty Tahr):released (1.4.16-1ubuntu2.5)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.4.20-1ubuntu3.2)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
Package
Upstream:released (1.4.22-5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.4.22-5)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.4.22-5)
Package
Upstream:released (2.2.8-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [2.0.22-3ubuntu1.4])
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.11-6ubuntu2.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.2.4-1ubuntu1.1)
Ubuntu 20.04 LTS (Focal Fossa):released (2.2.8-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla):released (2.2.8-1ubuntu1)
Package
Upstream:released (0.4.3-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (0.4.1-1ubuntu1.18.04.1)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (0.4.3-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (0.4.3-1ubuntu1)
More Information

Updated: 2020-10-24 06:47:52 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)