CVE-2018-11790

Priority
Description
When loading a document with Apache Open Office 4.1.5 and earlier with
smaller end line termination than the operating system uses, the defect
occurs. In this case OpenOffice runs into an Arithmetic Overflow at a
string length calculation.
Assigned-to
mdeslaur
Package
Upstream:released (1:5.0.3~rc1-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1:4.2.8-0ubuntu5.5)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1:5.1.6~rc2-0ubuntu1~xenial4)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:6.0.7-0ubuntu0.18.04.2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Patches:
Upstream:https://github.com/LibreOffice/core/commit/ae850353151cd6a79f7b4a012d0a411013c841a4
Upstream:https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-0&id=92eed31707e655e484e263fee2b0c0ae93d73748 (5.0)
More Information

Updated: 2019-02-06 23:15:03 UTC (commit c77dea2cc51b46a144a389f17f3ab3ae4dfd6f7c)