CVE-2018-1125

Priority
Description
procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in
pgrep. This vulnerability is mitigated by FORTIFY, as it involves strncat()
to a stack-allocated string. When pgrep is compiled with FORTIFY (as on Red
Hat Enterprise Linux and Fedora), the impact is limited to a crash.
Notes
 mdeslaur> [PATCH 008/117] pgrep: Prevent a potential stack-based buffer
 mdeslaur> overflow.
Assigned-to
mdeslaur
Package
Upstream:released (3.3.15)
Ubuntu 12.04 ESM (Precise Pangolin):released (1:3.2.8-11ubuntu6.6)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:3.3.9-1ubuntu2.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (2:3.3.10-4ubuntu2.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:3.3.12-3ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2:3.3.15-2ubuntu1)
Patches:
Upstream:https://gitlab.com/procps-ng/procps/commit/b51ca2a1f8ca779f7632ade6a0a259ed882fa584
More Information

Updated: 2019-01-14 22:31:15 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)