CVE-2018-1124

Priority
Description
procps-ng before version 3.3.15 is vulnerable to multiple integer overflows
leading to a heap corruption in file2strvec function. This allows a
privilege escalation for a local attacker who can create entries in procfs
by starting processes, which could result in crashes or arbitrary code
execution in proc utilities run by other users.
Notes
 mdeslaur> [PATCH 074/117] proc/readproc.c: Fix bugs and overflows in
 mdeslaur> file2strvec().
Assigned-to
mdeslaur
Package
Upstream:released (3.3.15)
Ubuntu 12.04 ESM (Precise Pangolin):released (1:3.2.8-11ubuntu6.5)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:3.3.9-1ubuntu2.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (2:3.3.10-4ubuntu2.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:3.3.12-3ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2:3.3.15-2ubuntu1)
Patches:
Upstream:https://gitlab.com/procps-ng/procps/commit/36c350f07c75aabf747fb833f52a234ae5781b20
More Information

Updated: 2018-10-22 14:14:22 UTC (commit 03ef231d584286304e54ae60f0de485bd42f2da8)