CVE-2018-1123

Priority
Description
procps-ng before version 3.3.15 is vulnerable to a denial of service in ps
via mmap buffer overflow. Inbuilt protection in ps maps a guard page at the
end of the overflowed buffer, ensuring that the impact of this flaw is
limited to a crash (temporary denial of service).
Notes
 mdeslaur> [PATCH 054/117] ps/output.c: Fix outbuf overflows in pr_args() etc.
Assigned-to
mdeslaur
Package
Upstream:released (3.3.15)
Ubuntu 12.04 ESM (Precise Pangolin):released (1:3.2.8-11ubuntu6.6)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:3.3.9-1ubuntu2.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (2:3.3.10-4ubuntu2.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:3.3.12-3ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2:3.3.15-2ubuntu1)
Patches:
Upstream:https://gitlab.com/procps-ng/procps/commit/136e3724952827bbae8887a42d9d2b6f658a48ab
More Information

Updated: 2019-01-14 22:31:15 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)