CVE-2018-1122 (retired)

Priority
Description
procps-ng before version 3.3.15 is vulnerable to a local privilege
escalation in top. If a user runs top with HOME unset in an
attacker-controlled directory, the attacker could achieve privilege
escalation by exploiting one of several vulnerabilities in the
config_file() function.
Notes
 mdeslaur> [PATCH 097/117] top: Do not default to the cwd in configs_read().
 leosilva> for precise/esm code request a POC test, and a huge backport.
Assigned-to
mdeslaur
Package
Upstream:released (3.3.15)
Ubuntu 12.04 ESM (Precise Pangolin):released (1:3.2.8-11ubuntu6.6)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:3.3.9-1ubuntu2.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (2:3.3.10-4ubuntu2.4)
Ubuntu 18.04 LTS (Bionic Beaver):released (2:3.3.12-3ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2:3.3.15-2ubuntu1)
Patches:
Upstream:https://gitlab.com/procps-ng/procps/commit/b45c4803dd176f4e3f9d3d47421ddec9bbbe66cd
More Information

Updated: 2019-03-26 12:26:55 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)