CVE-2018-10900 (retired)

Priority
Description
Network Manager VPNC plugin (aka networkmanager-vpnc) before version 1.2.6
is vulnerable to a privilege escalation attack. A new line character can be
used to inject a Password helper parameter into the configuration data
passed to VPNC, allowing an attacker to execute arbitrary commands as root.
Assigned-to
mikesalvatore
Package
Upstream:released (1.2.6)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.9.8.6-1ubuntu2.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.1.93-1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.2.4-6ubuntu0.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.2.6-1)
Patches:
Upstream:https://gitlab.gnome.org/GNOME/NetworkManager-vpnc/commit/07ac18a32b4e361a27ef48ac757d36cbb46e8e12
More Information

Updated: 2019-03-26 12:26:53 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)