CVE-2018-1089

Priority
Description
389-ds-base before versions 1.4.0.9, 1.3.8.1, 1.3.6.15 did not properly
handle long search filters with characters needing escapes, possibly
leading to buffer overflows. A remote, unauthenticated attacker could
potentially use this flaw to make ns-slapd crash via a specially crafted
LDAP request, thus resulting in denial of service.
Notes
Package
Upstream:released (1.3.8.2-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.3.8.2-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.3.8.2-1)
More Information

Updated: 2020-10-24 06:47:05 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)