CVE-2018-10873

Priority
Description
A vulnerability was discovered in SPICE before version 0.14.1 where the
generated code used for demarshalling messages lacked sufficient bounds
checks. A malicious client or server, after authentication, could send
specially crafted messages to its peer which would result in a crash or,
potentially, other impacts.
Assigned-to
leosilva
Notes
leosilvafor xenial this bug is affected in spice-protocol only.
Package
Source: spice (LP Ubuntu Debian)
Upstream:released (0.14.0-1.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (0.12.4-0nocelt2ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):released (0.14.0-1ubuntu2.2)
Ubuntu 20.04 LTS (Focal Fossa):released (0.14.0-1ubuntu4)
Ubuntu 20.10 (Groovy Gorilla):released (0.14.0-1ubuntu4)
Package
Upstream:released (0.35-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (0.35-2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (0.35-2)
Package
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.12.10-1ubuntu0.2)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 20.04 LTS (Focal Fossa):not-affected
Ubuntu 20.10 (Groovy Gorilla):not-affected
More Information

Updated: 2020-09-09 21:51:24 UTC (commit b67d7d8b03f173f825cd706df5bd078bca500b0e)