CVE-2018-1071

Priority
Medium
Description
zsh through version 5.4.2 is vulnerable to a stack-based buffer overflow in
the exec.c:hashcmd() function. A local attacker could exploit this to cause
a denial of service.
References
Bugs
Package
Source: zsh (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (5.0.2-3ubuntu6.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (5.1.1-1ubuntu2.2)
Ubuntu 17.10 (Artful Aardvark):released (5.2-5ubuntu1.2)
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
More Information

Updated: 2018-03-28 14:14:25 UTC (commit 14449)