CVE-2018-1067

Priority
Description
In Undertow before versions 7.1.2.CR1, 7.1.2.GA it was found that the fix
for CVE-2016-4993 was incomplete and Undertow web server is vulnerable to
the injection of arbitrary HTTP headers, and also response splitting, due
to insufficient sanitization and validation of user input before the input
is used as part of an HTTP header value.
Notes
Package
Upstream:released (1.4.25-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (2.0.29-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected
More Information

Updated: 2020-10-24 06:46:57 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)