CVE-2018-10393

Priority
Description
bark_noise_hybridmp in psy.c in Xiph.Org libvorbis 1.3.6 has a stack-based
buffer over-read.
Notes
 mdeslaur> same patch as CVE-2017-14160
Package
Upstream:released (1.3.6-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.04 (Disco Dingo):not-affected (1.3.6-2)
Ubuntu 19.10 (Eoan):not-affected (1.3.6-2)
Patches:
Upstream:https://gitlab.xiph.org/xiph/vorbis/commit/018ca26dece618457dd13585cad52941193c4a25
More Information

Updated: 2019-09-19 14:42:37 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)