CVE-2018-10017

Priority
Description
soundlib/Snd_fx.cpp in OpenMPT before 1.27.07.00 and libopenmpt before
0.3.8 allows remote attackers to cause a denial of service (out-of-bounds
read) via an IT or MO3 file with many nested pattern loops.
Ubuntu-Description
It was discovered that OpenMPT incorrectly handled certain failes. A remote
attacker could possibly use this issue to cause a denial of service.
Notes
Package
Upstream:released (0.3.8-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (0.3.11-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (0.3.11-1)
More Information

Updated: 2020-09-09 21:45:47 UTC (commit b67d7d8b03f173f825cd706df5bd078bca500b0e)