CVE-2018-1000876

Priority
Description
binutils version 2.32 and earlier contains a Integer Overflow vulnerability
in objdump,
bfd_get_dynamic_reloc_upper_bound,bfd_canonicalize_dynamic_reloc that can
result in Integer overflow trigger heap overflow. Successful exploitation
allows execution of arbitrary code.. This attack appear to be exploitable
via Local. This vulnerability appears to have been fixed in after commit
3a551c7a1b80fca579461774860574eabfd7f18f.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.04 (Disco Dingo):not-affected (2.32-7ubuntu4)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.32-8ubuntu1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.32-8ubuntu1)
Patches:
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=3a551c7a1b80fca579461774860574eabfd7f18f
More Information

Updated: 2019-12-05 19:51:45 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)