CVE-2018-1000805

Priority
Description
Paramiko version 2.4.1, 2.3.2, 2.2.3, 2.1.5, 2.0.8, 1.18.5, 1.17.6 contains
a Incorrect Access Control vulnerability in SSH server that can result in
RCE. This attack appear to be exploitable via network connectivity.
Notes
 ebarretto> with this issue, they decided to stop supporting versions 1.x
 mdeslaur> this issue is in the server code, not the client code
Assigned-to
mdeslaur
Package
Upstream:released (2.4.2)
Ubuntu 12.04 ESM (Precise Pangolin):released (1.7.7.1-2ubuntu1.2)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.10.1-1git1ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.16.0-1ubuntu0.2)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.0.0-1ubuntu1.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2.4.1-0ubuntu3.1)
Ubuntu 19.04 (Disco Dingo):released (2.4.1-0ubuntu3.1)
Patches:
Upstream:https://github.com/paramiko/paramiko/commit/56c96a659658acdbb873aef8809a7b508434dcce
More Information

Updated: 2018-11-01 12:15:04 UTC (commit d94e5aa8ffa67273e50bac0e105efdd1cb74fe7d)