CVE-2018-1000301 (retired)

Priority
Description
curl version curl 7.20.0 to and including curl 7.59.0 contains a CWE-126:
Buffer Over-read vulnerability in denial of service that can result in curl
can be tricked into reading data beyond the end of a heap based buffer used
to store downloaded RTSP content.. This vulnerability appears to have been
fixed in curl < 7.20.0 and curl >= 7.60.0.
Package
Source: curl (LP Ubuntu Debian)
Upstream:released (7.60.0)
Ubuntu 12.04 ESM (Precise Pangolin):released (7.22.0-3ubuntu4.21)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.35.0-1ubuntu2.16)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.47.0-1ubuntu2.8)
Ubuntu 18.04 LTS (Bionic Beaver):released (7.58.0-2ubuntu3.1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (7.58.0-2ubuntu4)
More Information

Updated: 2019-03-26 12:26:49 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)