CVE-2018-0735

Priority
Description
The OpenSSL ECDSA signature algorithm has been shown to be vulnerable to a
timing side channel attack. An attacker could use variations in the signing
algorithm to recover the private key. Fixed in OpenSSL 1.1.0j (Affected
1.1.0-1.1.0i). Fixed in OpenSSL 1.1.1a (Affected 1.1.1).
Assigned-to
mdeslaur
Notes
mdeslaurthis may be introduced by the fix for CVE-2018-5407
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (1.0.1f-1ubuntu2.26)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (1.0.2g-1ubuntu4.13)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.1.0g-2ubuntu4.3)
Ubuntu 20.04 LTS (Focal Fossa):released (1.1.1a-1ubuntu2)
Ubuntu 20.10 (Groovy Gorilla):released (1.1.1a-1ubuntu2)
Patches:
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=b1d6d55ece1c26fa2829e2b819b038d7b6d692b4 (1.1.1)
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=56fb454d281a023b3f950d969693553d3f3ceea1 (1.1.0)
Upstream:https://git.openssl.org/?p=openssl.git;a=commit;h=003f1bfd185267cc67ac9dc521a27d7a2af0d0ee (1.1.0)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.0.2n-1ubuntu5.1)
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
More Information

Updated: 2020-09-09 21:41:08 UTC (commit b67d7d8b03f173f825cd706df5bd078bca500b0e)