CVE-2017-9870

Priority
Description
The III_i_stereo function in layer3.c in mpglib, as used in libmpgdecoder.a
in LAME 3.99.5 and other products, allows remote attackers to cause a
denial of service (buffer over-read and application crash) via a crafted
audio file that is mishandled in the code for the "block_type == 2" case, a
similar issue to CVE-2017-11126.
Notes
ratliffreproducer doesn't crash on zesty (no ASAN)
no patch available on 2017-06-26
Package
Source: lame (LP Ubuntu Debian)
Upstream:released (3.99.5+repack1-8)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.99.5+repack1-9build1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.100-2)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (3.100-2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (3.100-2)
More Information

Updated: 2020-09-09 21:40:48 UTC (commit b67d7d8b03f173f825cd706df5bd078bca500b0e)