CVE-2017-9865 (retired)

Priority
Description
The function GfxImageColorMap::getGray in GfxState.cc in Poppler 0.54.0
allows remote attackers to cause a denial of service (stack-based buffer
over-read and application crash) via a crafted PDF document, related to
missing color-map validation in ImageOutputDev.cc.
Notes
 ratliff> reproducer didn't crash on t-z (no ASAN)
Assigned-to
mdeslaur
Package
Upstream:released (0.57.0-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.41.0-0ubuntu1.14)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.57.0-2ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.57.0-2ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.57.0-2ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (0.57.0-2ubuntu1)
Patches:
Upstream:https://cgit.freedesktop.org/poppler/poppler/commit/?id=75fff6556eaf0ef3a6fcdef2c2229d0b6d1c58d9
More Information

Updated: 2019-06-27 15:14:54 UTC (commit 7a5ea7be120f4f206b17c69a41f9eca65543f722)