CVE-2017-9835

Priority
Medium
Description
The gs_alloc_ref_array function in psi/ialloc.c in Artifex Ghostscript 9.21
allows remote attackers to cause a denial of service (heap-based buffer
overflow and application crash) or possibly have unspecified other impact
via a crafted PostScript document. This is related to a lack of an integer
overflow check in base/gsalloc.c.
References
Bugs
Assigned-to
leosilva
Package
Upstream:needed
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (9.10~dfsg-0ubuntu10.10)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.18~dfsg~0-0ubuntu2.7)
Ubuntu 17.04 (Zesty Zapus):released (9.19~dfsg+1-0ubuntu7.6)
Patches:
Upstream:http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=cfde94be1d4286bc47633c6e6eaf4e659bd78066
More Information

Updated: 2017-08-28 19:14:14 UTC (commit 13216)