CVE-2017-9788

Priority
Medium
Description
In Apache httpd before 2.2.34 and 2.4.x before 2.4.27, the value
placeholder in [Proxy-]Authorization headers of type 'Digest' was not
initialized or reset before or between successive key=value assignments by
mod_auth_digest. Providing an initial key with no '=' assignment could
reflect the stale value of uninitialized pool memory used by the prior
request, leading to leakage of potentially confidential information, and a
segfault in other cases resulting in denial of service.
References
Assigned-to
mdeslaur
Package
Upstream:released (2.4.27)
Ubuntu 17.10 (Artful Aardvark):released (2.4.27-2ubuntu2)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.2.22-1ubuntu1.13)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.4.7-1ubuntu4.17)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4.18-2ubuntu3.4)
Ubuntu 17.04 (Zesty Zapus):released (2.4.25-3ubuntu2.2)
Patches:
Upstream:https://github.com/apache/httpd/commit/549ba6a39aa0df78a610025f74f3a06503a70f67 (2.4)
Upstream:https://svn.apache.org/viewvc?view=revision&revision=1800955
More Information

Updated: 2017-08-11 23:56:02 UTC (commit 13081)