CVE-2017-9765

Priority
Description
Integer overflow in the soap_get function in Genivia gSOAP 2.7.x and 2.8.x
before 2.8.48, as used on Axis cameras and other devices, allows remote
attackers to execute arbitrary code or cause a denial of service
(stack-based buffer overflow and application crash) via a large XML
document, aka Devil's Ivy. NOTE: the large document would be blocked by
many common web-server configurations on general-purpose computers.
Package
Source: gsoap (LP Ubuntu Debian)
Upstream:released (2.8.48-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.8.60-2build1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (2.8.60-2build1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.8.60-2build1)
Ubuntu 19.10 (Eoan):not-affected (2.8.60-2build1)
Patches:
Distro:https://bugzilla.suse.com/attachment.cgi?id=733005&action=diff
More Information

Updated: 2019-04-26 14:24:54 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)