CVE-2017-9471

Priority
Description
In ytnef 1.9.2, the SwapWord function in lib/ytnef.c allows remote
attackers to cause a denial of service (heap-based buffer over-read and
application crash) via a crafted file.
Notes
Package
Upstream:released (1.9.3-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1.5-6ubuntu0.2])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.9.3-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.9.3-1)
Patches:
Upstream:https://github.com/Yeraze/ytnef/pull/56/commits/01fdb170339e60a59a2d247edca95cce646fa4d7
More Information

Updated: 2020-10-24 06:44:42 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)