CVE-2017-9239

Priority
Description
An issue was discovered in Exiv2 0.26. When the data structure of the
structure ifd is incorrect, the program assigns pValue_ to 0x0, and the
value of pValue() is 0x0. TiffImageEntry::doWriteImage will use the value
of pValue() to cause a segmentation fault. To exploit this vulnerability,
someone must open a crafted tiff file.
Package
Source: exiv2 (LP Ubuntu Debian)
Upstream:released (0.25-3.1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.23-1ubuntu2.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.25-2.1ubuntu16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.25-3.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.25-3.1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.25-3.1)
Patches:
Upstream:https://github.com/Exiv2/exiv2/commit/2f8681e120d277e418941c4361c83b5028f67fd8
More Information

Updated: 2019-01-14 22:31:02 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)