CVE-2017-9058

Priority
Description
In libytnef in ytnef through 1.9.2, there is a heap-based buffer over-read
due to incorrect boundary checking in the SIZECHECK macro in lib/ytnef.c.
Notes
sarnoldThe fix is to a macro; I didn't see any uses in main but there
may be some in universe
Package
Upstream:released (1.9.2-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1.5-6ubuntu0.2])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.9.2-2)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.9.2-2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.9.2-2)
Patches:
Distro:http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=862556
More Information

Updated: 2020-10-24 06:44:02 UTC (commit 69e225d81a6ee3e2e014950178db797c5d4e5009)