CVE-2017-9050

Priority
Description
libxml2 20904-GITv2.9.4-16-g0741801 is vulnerable to a heap-based buffer
over-read in the xmlDictAddString function in dict.c. This vulnerability
causes programs that use libxml2, such as PHP, to crash. This vulnerability
exists because of an incomplete fix for CVE-2016-1839.
Notes
 mdeslaur> probably same issue as CVE-2017-9049
Package
Upstream:released (2.9.4+dfsg1-3.1)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.7.8.dfsg-5.1ubuntu4.18)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.9.1+dfsg1-3ubuntu4.10)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.9.3+dfsg1-1ubuntu0.3)
Patches:
Upstream:https://git.gnome.org/browse/libxml2/commit/?id=e26630548e7d138d2c560844c43820b6767251e3
More Information

Updated: 2019-01-14 22:31:00 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)