CVE-2017-9022

Priority
Medium
Description
The gmp plugin in strongSwan before 5.5.3 does not properly validate RSA
public keys before calling mpz_powm_sec, which allows remote peers to cause
a denial of service (floating point exception and process crash) via a
crafted certificate.
References
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):released (5.5.1-4ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (5.1.2-0ubuntu2.6)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (5.3.5-1ubuntu3.3)
Ubuntu 17.04 (Zesty Zapus):released (5.5.1-1ubuntu3.1)
More Information

Updated: 2017-08-11 23:56:01 UTC (commit 13081)