CVE-2017-8872

Priority
Description
The htmlParseTryOrFinish function in HTMLparser.c in libxml2 2.9.4 allows
attackers to cause a denial of service (buffer over-read) or information
disclosure.
Notes
mdeslaurfix debian used isn't the final upstream fix
Package
Upstream:released (2.9.4+dfsg1-6.1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (2.9.4+dfsg1-6.1ubuntu1)
Ubuntu 19.04 (Disco Dingo):released (2.9.4+dfsg1-6.1ubuntu1)
Ubuntu 19.10 (Eoan Ermine):released (2.9.4+dfsg1-6.1ubuntu1)
Ubuntu 20.04 (Focal Fossa):released (2.9.4+dfsg1-6.1ubuntu1)
Patches:
Upstream:https://gitlab.gnome.org/GNOME/libxml2/commit/123234f2cfcd9e9b9f83047eee1dc17b4c3f4407
More Information

Updated: 2020-01-06 16:19:59 UTC (commit 8ff056d255cdc03c0a3181822a6495d969c4f13a)