CVE-2017-7826

Priority
Description
Memory safety bugs were reported in Firefox 56 and Firefox ESR 52.4. Some
of these bugs showed evidence of memory corruption and we presume that with
enough effort that some of these could be exploited to run arbitrary code.
This vulnerability affects Firefox < 57, Firefox ESR < 52.5, and
Thunderbird < 52.5.
Assigned-to
chrisccoulson
Notes
tyhicksmozjs contains a copy of the SpiderMonkey JavaScript engine
Package
Upstream:released (57.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [57.0+build4-0ubuntu0.14.04.4])
Ubuntu 16.04 LTS (Xenial Xerus):released (57.0+build4-0ubuntu0.16.04.5)
Ubuntu 18.04 LTS (Bionic Beaver):released (57.0.1+build2-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa):released (57.0.1+build2-0ubuntu1)
Ubuntu 20.10 (Groovy Gorilla):released (57.0.1+build2-0ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 20.04 LTS (Focal Fossa):DNE
Ubuntu 20.10 (Groovy Gorilla):DNE
Package
Upstream:released (52.5.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):released (52.8.1-0ubuntu0.18.04.1)
Ubuntu 20.04 LTS (Focal Fossa):needed
Ubuntu 20.10 (Groovy Gorilla):needed
Package
Priority: Low
Upstream:released (52.5.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [1:52.5.0+build1-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (1:52.5.0+build1-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:52.6.0+build1-0ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa):released (1:52.6.0+build1-0ubuntu1)
Ubuntu 20.10 (Groovy Gorilla):released (1:52.6.0+build1-0ubuntu1)
More Information

Updated: 2020-07-28 18:46:36 UTC (commit 7b6828437fde0509248708fcdb5b0f7587b85bd1)