CVE-2017-7813

Priority
Description
Inside the JavaScript parser, a cast of an integer to a narrower type can
result in data read from outside the buffer being parsed. This usually
results in a non-exploitable crash, but can leak a limited amount of
information from memory if it matches JavaScript identifier syntax. This
vulnerability affects Firefox < 56.
Notes
 tyhicks> mozjs contains a copy of the SpiderMonkey JavaScript engine
Assigned-to
chrisccoulson
Package
Upstream:released (56.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE (trusty was released [56.0+build6-0ubuntu0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):released (56.0+build6-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (56.0+build6-0ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (56.0+build6-0ubuntu1)
Ubuntu 19.04 (Disco Dingo):released (56.0+build6-0ubuntu1)
Ubuntu 19.10 (Eoan):released (56.0+build6-0ubuntu1)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):needs-triage
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:not-affected
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
More Information

Updated: 2019-04-26 14:24:15 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)