CVE-2017-7748

Priority
Medium
Description
In Wireshark 2.2.0 to 2.2.5 and 2.0.0 to 2.0.11, the WSP dissector could go
into an infinite loop, triggered by packet injection or a malformed capture
file. This was addressed in epan/dissectors/packet-wsp.c by adding a length
check.
References
Package
Upstream:released (2.2.6, 2.0.12)
Ubuntu 17.10 (Artful Aardvark):released (2.2.6+g32dac6a-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.2.6+g32dac6a-2ubuntu0.16.04)
Ubuntu 17.04 (Zesty Zapus):released (2.2.6+g32dac6a-2ubuntu0.17.04)
Patches:
Upstream:https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=f55cbcde2c8f74b652add4450b0592082eb6acff
More Information

Updated: 2017-08-11 23:26:38 UTC (commit 13081)