CVE-2017-7747

Priority
Medium
Description
In Wireshark 2.2.0 to 2.2.5 and 2.0.0 to 2.0.11, the PacketBB dissector
could crash, triggered by packet injection or a malformed capture file.
This was addressed in epan/dissectors/packet-packetbb.c by restricting
additions to the protocol tree.
References
Package
Upstream:released (2.2.6, 2.0.12)
Ubuntu 17.10 (Artful Aardvark):released (2.2.6+g32dac6a-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):released (2.2.6+g32dac6a-2ubuntu0.16.04)
Ubuntu 17.04 (Zesty Zapus):released (2.2.6+g32dac6a-2ubuntu0.17.04)
Patches:
Upstream:https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=5cfd52d6629cf8a7ab67c6bacd3431a964f43584
More Information

Updated: 2017-10-23 12:32:25 UTC (commit 13562)