CVE-2017-7700

Priority
Medium
Description
In Wireshark 2.2.0 to 2.2.5 and 2.0.0 to 2.0.11, the NetScaler file parser
could go into an infinite loop, triggered by a malformed capture file. This
was addressed in wiretap/netscaler.c by ensuring a nonzero record size.
References
Package
Upstream:released (2.2.6, 2.0.12)
Ubuntu 12.04 LTS (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Touch 15.04:DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 16.10 (Yakkety Yak):needed
Ubuntu 17.04 (Zesty Zapus):needed
Patches:
Upstream:https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=8fc0af859de4993951a915ad735be350221f3f53
More Information

Updated: 2017-04-14 08:33:40 UTC (commit 12390)