CVE-2017-7585

Priority
Low
Description
In libsndfile before 1.0.28, an error in the "flac_buffer_copy()" function
(flac.c) can be exploited to cause a stack-based buffer overflow via a
specially crafted FLAC file.
References
Assigned-to
mdeslaur
Package
Upstream:released (1.0.27-2)
Ubuntu 17.10 (Artful Aardvark):not-affected (1.0.27-3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (1.0.25-7ubuntu2.2)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.25-10ubuntu0.16.04.1)
Ubuntu 17.04 (Zesty Zapus):released (1.0.27-1ubuntu0.1)
Patches:
Distro:https://sources.debian.net/data/main/libs/libsndfile/1.0.27-2/debian/patches/fix_bufferoverflows.patch
Upstream:https://github.com/erikd/libsndfile/commit/60b234301adf258786d8b90be5c1d437fc8799e0
More Information

Updated: 2017-08-11 23:55:57 UTC (commit 13081)