CVE-2017-7521

Priority
Description
OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote
denial-of-service due to memory exhaustion caused by memory leaks and
double-free issue in extract_x509_extension().
Assigned-to
mdeslaur
Notes
leosilvaas debian wheezy, precise-esm is not affected, code not present.
Package
Upstream:released (2.4.3, 2.3.17)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.3.2-7ubuntu3.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.10-1ubuntu2.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.4.0-5ubuntu2)
Patches:
Upstream:https://github.com/OpenVPN/openvpn/commit/cb4e35ece4 (master)
Upstream:https://github.com/OpenVPN/openvpn/commit/0400840671 (2.4)
Upstream:https://github.com/OpenVPN/openvpn/commit/1dde0cd6e5 (2.3)
More Information

Updated: 2019-12-05 18:49:34 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)