CVE-2017-7520

Priority
Description
OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to
denial-of-service and/or possibly sensitive memory leak triggered by
man-in-the-middle attacker.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (2.4.3, 2.3.17)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.2.1-8ubuntu1.5)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.3.2-7ubuntu3.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.10-1ubuntu2.1)
Patches:
Upstream:https://github.com/OpenVPN/openvpn/commit/7718c8984f (master)
Upstream:https://github.com/OpenVPN/openvpn/commit/043fe32787 (2.4)
Upstream:https://github.com/OpenVPN/openvpn/commit/f38a4a1059 (2.3)
Upstream:https://github.com/OpenVPN/openvpn/commit/4bec9d25d5 (2.2)
More Information

Updated: 2019-12-05 18:49:34 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)