CVE-2017-7508

Priority
Description
OpenVPN versions before 2.4.3 and before 2.3.17 are vulnerable to remote
denial-of-service when receiving malformed IPv6 packet.
Assigned-to
mdeslaur
Notes
leosilvasame as debian wheezy for precise-esm it's not affected
Package
Upstream:released (2.4.3, 2.3.17)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.3.2-7ubuntu3.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.10-1ubuntu2.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.4.0-5ubuntu2)
Patches:
Upstream:https://github.com/OpenVPN/openvpn/commit/c3f47077a7 (master)
Upstream:https://github.com/OpenVPN/openvpn/commit/ed28cde3d8 (2.4)
Upstream:https://github.com/OpenVPN/openvpn/commit/fc61d1bda1 (2.3)
More Information

Updated: 2019-12-05 18:49:34 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)