CVE-2017-7481

Priority
Description
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark
lookup-plugin results as unsafe. If an attacker could control the results
of lookup() calls, they could inject Unicode strings to be parsed by the
jinja2 templating system, resulting in code execution. By default, the
jinja2 templating language is now marked as 'unsafe' and is not evaluated.
Notes
Package
Upstream:released (2.3.1.0+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):released (2.0.0.2-2ubuntu1.3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.5.1+dfsg-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.6.1+dfsg-1)
Ubuntu 19.10 (Eoan):not-affected (2.6.1+dfsg-1)
Patches:
Upstream:https://github.com/ansible/ansible/commit/ed56f51f185a1ffd7ea57130d260098686fcc7c2
More Information

Updated: 2019-10-18 02:34:15 UTC (commit cccfc4426d8c1fbf582a89d981fe7fc812124543)