CVE-2017-7479

Priority
Low
Description
OpenVPN versions before 2.3.15 and before 2.4.2 are vulnerable to reachable
assertion when packet-ID counter rolls over resulting into Denial of
Service of server by authenticated attacker.
Ubuntu-Description
It was discovered that OpenVPN improperly triggered an assert when
packet ids rolled over. An authenticated remote attacker could use
this to cause a denial of service (application crash).
References
Bugs
Notes
 sbeattie> fix needs a87e1431baccd49a9344cfc63ab7446c4317fa2f (2.4) or
  5d747770efa0611cc6cfeb6b3a5853bf51046d53 (2.3) as a prequisite
Assigned-to
mdeslaur
Package
Upstream:released (2.4.0-5)
Ubuntu 17.10 (Artful Aardvark):not-affected (2.4.0-5ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):released (2.3.2-7ubuntu3.2)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.3.10-1ubuntu2.1)
Ubuntu 17.04 (Zesty Zapus):released (2.4.0-4ubuntu1.2)
Patches:
Upstream:https://github.com/OpenVPN/openvpn/commit/b727643cdf4e078f132a90e1c474a879a5760578 (2.3)
Upstream:https://github.com/OpenVPN/openvpn/commit/591a4e574c43cb9e820950f15dcaabda261def78 (2.4)
More Information

Updated: 2017-08-11 23:26:28 UTC (commit 13081)