CVE-2017-7377

Priority
Description
The (1) v9fs_create and (2) v9fs_lcreate functions in hw/9pfs/9p.c in QEMU
(aka Quick Emulator) allow local guest OS privileged users to cause a
denial of service (file descriptor or memory consumption) via vectors
related to an already in-use fid.
Notes
 tyhicks> A privileged user in the guest can leak host memory
 tyhicks> Affected code is in hw/9pfs/virtio-9p.c in older releases
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Trusty/esm:released (2.0.0+dfsg-2ubuntu1.34)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:2.5+dfsg-5ubuntu10.14)
Ubuntu 18.04 LTS (Bionic Beaver):released (1:2.8+dfsg-3ubuntu3)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1:2.8+dfsg-3ubuntu3)
Ubuntu 19.04 (Disco Dingo):released (1:2.8+dfsg-3ubuntu3)
Ubuntu 19.10 (Eoan):released (1:2.8+dfsg-3ubuntu3)
Patches:
Upstream:http://git.qemu-project.org/?p=qemu.git;a=commit;h=d63fb193e71644a073b77ff5ac6f1216f2f6cf6e
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):needed
Trusty/esm:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:23:54 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)