CVE-2017-7301

Priority
Description
The Binary File Descriptor (BFD) library (aka libbfd), as distributed in
GNU Binutils 2.28, has an aout_link_add_symbols function in bfd/aoutx.h
that has an off-by-one vulnerability because it does not carefully check
the string offset. The vulnerability could lead to a GNU linker (ld)
program crash.
Notes
Package
Upstream:released (2.27.51.20161212-1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.28-1ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.28-1ubuntu1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.28-1ubuntu1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.28-1ubuntu1)
Patches:
Upstream:https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=daae68f4f372e0618d6b9c64ec0f1f74eae6ab3d
More Information

Updated: 2019-12-05 19:49:33 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)