CVE-2017-7244

Priority
Description
The _pcre32_xclass function in pcre_xclass.c in libpcre1 in PCRE 8.40
allows remote attackers to cause a denial of service (invalid memory read)
via a crafted file.
Notes
mdeslaurpcre32 support enabled only in pcre3/1:8.35-4
same commit as CVE-2017-7186
Package
Source: pcre3 (LP Ubuntu Debian)
Upstream:released (2:8.39-3)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2:8.39-3)
Ubuntu 19.04 (Disco Dingo):not-affected (2:8.39-3)
Ubuntu 19.10 (Eoan Ermine):not-affected (2:8.39-3)
Ubuntu 20.04 (Focal Fossa):not-affected (2:8.39-3)
Patches:
Upstream:https://vcs.pcre.org/pcre?view=revision&revision=1688
More Information

Updated: 2019-12-05 19:49:32 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)