CVE-2017-6831

Priority
Medium
Description
Heap-based buffer overflow in the decodeBlockWAVE function in IMA.cpp in
Audio File Library (aka audiofile) 0.3.6 allows remote attackers to cause a
denial of service (crash) via a crafted file.
References
Bugs
Package
Upstream:released (0.3.6-4)
Ubuntu 14.04 LTS (Trusty Tahr):released (0.3.6-2ubuntu0.14.04.2)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (0.3.6-2ubuntu0.16.04.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (0.3.6-4)
Patches:
Upstream:https://github.com/antlarr/audiofile/commit/a2e9eab8ea87c4ffc494d839ebb4ea145eb9f2e6
More Information

Updated: 2017-08-11 23:55:55 UTC (commit 13081)