CVE-2017-6437

Priority
Negligible
Description
The base64encode function in base64.c in libimobiledevice libplist 1.12
allows local users to cause a denial of service (out-of-bounds read) via a
crafted plist file.
References
Bugs
Notes
 ratliff> vanilla 1.12 does not suffer this issue, it was most likely introduced
 ratliff> during the post-1.12 refactoring of parse_bin_node
Package
Upstream:released (1.12+git+1+e37ca00-0.2)
Ubuntu 17.10 (Artful Aardvark):not-affected (1.12+git+1+e37ca00-0.3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Patches:
Upstream:https://github.com/libimobiledevice/libplist/commit/dccd9290745345896e3a4a73154576a599fd8b7b
More Information

Updated: 2017-08-11 23:26:06 UTC (commit 13081)