CVE-2017-6369

Priority
Description
Insufficient checks in the UDF subsystem in Firebird 2.5.x before 2.5.7 and
3.0.x before 3.0.2 allow remote authenticated users to execute code by
using a 'system' entrypoint from fbudf.so.
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):released ([2.5.2.26540.ds4-9ubuntu1.1])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Package
Upstream:released (3.0.1.32609.ds4-14)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.0.2.32703.ds4-11ubuntu2)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (3.0.2.32703.ds4-11ubuntu2)
Ubuntu 19.04 (Disco Dingo):not-affected (3.0.2.32703.ds4-11ubuntu2)
Ubuntu 19.10 (Eoan):not-affected (3.0.2.32703.ds4-11ubuntu2)
More Information

Updated: 2019-05-15 17:16:48 UTC (commit 2d71aefac924bf16479c12958688c37878e881eb)