CVE-2017-6318

Priority
Description
saned in sane-backends 1.0.25 allows remote attackers to obtain sensitive
memory information via a crafted SANE_NET_CONTROL_OPTION packet.
Assigned-to
mdeslaur
Notes
Package
Upstream:released (1.0.25-4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.25+git20150528-1ubuntu2.16.04.3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.0.27-1~experimental3ubuntu2)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (1.0.27-1~experimental3ubuntu2)
Ubuntu 20.10 (Groovy Gorilla):not-affected (1.0.27-1~experimental3ubuntu2)
Patches:
Upstream:https://anonscm.debian.org/cgit/sane/sane-backends.git/commit/frontend/saned.c?id=42896939822b44f44ecd1b6d35afdfa4473ed35d
Upstream:https://gitlab.com/sane-project/backends/-/commit/42896939822b44f44ecd1b6
More Information

Updated: 2020-09-10 05:40:36 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)