CVE-2017-6056

Priority
Medium
Description
It was discovered that a programming error in the processing of HTTPS
requests in the Apache Tomcat servlet and JSP engine may result in denial
of service via an infinite loop. The denial of service is easily achievable
as a consequence of backporting a CVE-2016-6816 fix but not backporting the
fix for Tomcat bug 57544. Distributions affected by this backporting issue
include Debian (before 7.0.56-3+deb8u8 and 8.0.14-1+deb8u7 in jessie) and
Ubuntu.
References
Bugs
Package
Upstream:released (7.0.60)
Ubuntu 17.10 (Artful Aardvark):not-affected (7.0.75-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.0.52-1ubuntu0.10)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (7.0.68-1ubuntu0.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (7.0.75-1)
Patches:
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1657910
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1658209
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):released (6.0.35-1ubuntu3.11)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):DNE
Patches:
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1659539
Package
Upstream:released (8.0.19)
Ubuntu 17.10 (Artful Aardvark):not-affected (8.0.38-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (8.0.32-1ubuntu1.3)
Ubuntu 17.04 (Zesty Zapus):not-affected (8.0.38-2)
More Information

Updated: 2017-08-11 23:25:59 UTC (commit 13081)